Won't pull - Yamaha Grizzly Forum : GrizzlyOwners.Com Yamaha Grizzly Forums
 1Likes
  • 1 Post By AnthonyS
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 10-14-2018, 10:07 PM Thread Starter
Junior Member
 
Join Date: Oct 2018
Location: Lafayette TN
Posts: 3
Won't pull

I have a 2010, 700 grizzly it was loosing power so I put a new clutch and belt but it still don't have any power in drive or reverse, can anyone help

Last edited by AnthonyS; 10-14-2018 at 11:52 PM. Reason: Didn't sound right
AnthonyS is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-15-2018, 10:42 AM Thread Starter
Junior Member
 
Join Date: Oct 2018
Location: Lafayette TN
Posts: 3
Lightbulb Info

It has a wet clutch behind the clutch i just changed so wish me luck changing this and hope this works.
MyBoyBlue likes this.
AnthonyS is offline  
post #3 of 3 (permalink) Old 10-17-2018, 10:26 PM
Junior Member
 
MyBoyBlue's Avatar
 
Join Date: Nov 2017
Location: Unfortunately, New Jersey
Posts: 3
Garage
Quote:
Originally Posted by AnthonyS View Post
It has a wet clutch behind the clutch i just changed so wish me luck changing this and hope this works.


Did it solve your issue?

2016 Grizzly 700 Green
Purple Spring
1mm Shim
Kenda Bear Claw HTRs
EHS Tuner
MyBoyBlue is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Grizzly Forum : GrizzlyOwners.Com Yamaha Grizzly Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome