Yamaha Grizzly Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am working on a 2000 Yamaha grizzly 600 and the battery is good at 12.8 volts and when I hit the starter button the oil temp light goes on and the quad will not start. If I cross over the starter relay the motor turns over. I go another left hand handle bar ass. and it does the same thing. Does anyone have any idea's?
 

·
Registered
Joined
·
9 Posts
I had some odd starter and oil temp. light issues on my Grizzly, it may not help you or be your issue but worth a look.
I had a short in the wiring harness, if you take the seat off inspect the harness, on my 1999 it ran along the right side of the frame just under the seat. My opinion it’s poorly run from the factory, with age mine wore the insulation off a wire causing a short. My starter kicked in and out while running along with lighting up the oil temp warning bulb. Mine ate up a starter and flywheel before I figured it out.
 

·
Registered
Joined
·
2 Posts
Why not just leave the group rather than being judgemental? Don't everexpect any help out of me.. I hope the rest of the groups follow suit smartalec.....
It was a legit question. Not being a smartalec
Judgemental? You’ve set the example mate. Let’s calm down and realize a 600 isn’t a 660. That’s all. Nothing personal. If you withhold help from me over this then I hope that satisfies your rage.
 

·
Registered
Joined
·
22 Posts
I'm 70 years old and figured he had just made a mistake and choosed not to say anything about it. You on the other hand was the judgemental one- not me. Why did you have to say that rather than just be what I took as sarcasm?
Judge and be judged.
I've never met a dog I haven't liked.
Just some of their owners.....
 
1 - 9 of 9 Posts
Top