Yamaha Grizzly Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello All,
I have a 2011 grizzly 700 EFI & sometimes it will not start/fire. It cranks over but will not start, sometimes if I push the throttle it will fire up & spit/backfire but then run fine for the rest of the day. I try to start it again a few days later & sometimes it starts no problem but many many times it will not start up. Before this started to happen I was running it all day & I stopped to fuel up & when I removed the gas cap gas sprayed out of the gas tank like it was Niagara Falls. I fueled up & it started back up. Shortly after this is when the hard start issue started. I took it into a yamaha dealer who could not find the problem, however it started every time for them (of course!) they cleaned out the fuel, new plug. It was ok for a few days then started acting up again. Once it does fire up it runs like its brand new, zero issues & plenty of power & only has 2600 miles on it. So seems to me a fuel issue? I'm thinking maybe the pump however I disconnected the line going to the pump (under the seat) & fuel poured out. The dealer said my valves were in spec also. To me it's something with the fuel system. Maybe a sensor, some sort of fuel pressure leak within the system. I did read an article that it could also be the gas tank rollover valve which is what maybe caused the hissing noise I heard when I removed the cap & fuel sprayed out? Any ideas/suggestions would be appreciated. Thank you.
 
1 - 1 of 1 Posts
Top