Yamaha Grizzly Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
seems to be so far when it is first warming up if it was going down a hill without giving gas it will act like it is coming out of gear then if i touch the brakes it kicks back in. it did it a little bit so i greased my clutch. (thanks texmudder for your page). it still does so maybe my belt is wore, it looked good while i was in there. i have a 02 grizzly 660 with 3600 miles.it has been a great bike
 

·
Registered
Joined
·
256 Posts
Mine started doing this last week right after I got my clutch cleaned. However, it doesn't kick back into gear when I brake...only when I give some throttle
 

·
Registered
Joined
·
256 Posts
Anybody knows what could be causing this?
 

·
Premium Member
Joined
·
620 Posts
This sounds like either a belt or clutching issue... I know the clutches control the engine braking, but I don't know the Grizzly's clutch design well enough to speculate as to an exact cause.

Rob
 

·
Premium Member
Joined
·
2,962 Posts
If you use automotive oil with friction inhibitors, would that cause it. I guess i don't know much about the Griz clutch either.
 

·
Registered
Joined
·
78 Posts
starky it would just make the wet clutch slip....I always use Yamalube 20-40 so thats never an issue. For what little extra I pay for the Yamalube its well worth it to me and my dealer treats me really well so I have no problem supporting him by getting my oil and filters from him.
The one way bearing is about the same as on the shifter quads with the auto clutches.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #10
i have always used the yamaha oil but not there filter. i am just going to change the 1 way bearing. it is a pain in the rear with out my engine brake. i hate using my brakes unless i am going to stop. i found a hole the other day that was way too deep for me. never been that deep. filled my clutch case and even had some in with my sparkplug . now i carry a disposeable camera. i know this goes somewhere else in the forum but i am already here .
 

·
Registered
Joined
·
1 Posts
I have a similar problem. It seems to only happen when the machine is first driven after it has just warmed up, then after I drive it a while, it doesn't do it anymore. You can hear the engine brake disengage and it free wheels until I tap the throttle. I just had a tune up and valve adjustment done and it started after that, but I can't imagine anything involved in that would have anything to do with the clutch involved in engine braking.
 

·
Registered
Joined
·
2 Posts
Ill second the wet clutch one way bearing. Mine always did the same thing since I got it, figured it was kind of normal. I was coming down a pretty bill hill hot and heavy one night letting the motor hold me back and all of a sudden the clutch was "locked up" stalled when I came to a stop. After I tore it apart I found the nut on the crank holding the wet clutch on actually backed off and got jammed into the drum. I had already ordered all new stuff but all I needed was the bearing, nut and drum. Now the problem is gone.
 
1 - 12 of 12 Posts
Top