Yamaha Grizzly Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2002 Yamaha 660 Grizzly. I rebuilt the carb due to running poorly, after re-installation the Griz started fine and ran great. After a few minutes it started stalling and fuel was pouring out of the overflow tube in the float bowl. I rebuilt the carb after buying a new one and it having the same issue. Im assuming the needle is not seating properly so I adjusted the float level, same issue. The only thing I can think of now is there is debris in my fuel tank which plug to inlet so the needle doesn't seat properly.

Any help would be greatly appreciated.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
I have been reading every thread on every forum I can find and can't find a solution. I will pull the carb, take off the float bowl, attach a long fuel line to the carb, fill the line with water and manually work the float to see if I shuts off the fuel. If it does shut off the fuel, hopefully I will be able to find a leak somewhere else.
 

·
Registered
Joined
·
3 Posts
Some times the tang is bent not allowing it to push up against the needle valve. you can usually just bend the tang ever so slightly and see that it will push the needle up when the float rises. If you go in that far you might as well blow everything out as well.
 

·
Registered
Joined
·
10 Posts
I recently ordered a new carb for my '02 yfm 660. It was spitting, sputtering, fuel pouring out of the overflow. Installed new carb. Piece of junk. Disassembled and cleaned old carb, adjusted the floats. Found dirt in the needle seat. Took care of that. Reinstalled carb. Same problem. I've taken it apart AT LEAST 10 times!!!!!!!!!! Been rebuilding carbs All my life. I'm 70 yrs old. YES, I still ride!! lol. I cured the flooding problem and it still would not run properly. Ordered a new cdi module. Junk. No starter circuit in the new one. Ordered another!!! Same thing!! Chinese JUNK. I just ordered a carb rebuild kit. Keeping my fingers crossed. 4200 miles on this machine and I've NEVER had so much as a hiccup. Anyone else out there have the same issues. Driving me nuts. I need my machine!!!!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
10 Posts
I recently ordered a new carb for my '02 yfm 660. It was spitting, sputtering, fuel pouring out of the overflow. Installed new carb. Piece of junk. Disassembled and cleaned old carb, adjusted the floats. Found dirt in the needle seat. Took care of that. Reinstalled carb. Same problem. I've taken it apart AT LEAST 10 times!!!!!!!!!! Been rebuilding carbs All my life. I'm 70 yrs old. YES, I still ride!! lol. I cured the flooding problem and it still would not run properly. Ordered a new cdi module. Junk. No starter circuit in the new one. Ordered another!!! Same thing!! Chinese JUNK. I just ordered a carb rebuild kit. Keeping my fingers crossed. 4200 miles on this machine and I've NEVER had so much as a hiccup. Anyone else out there have the same issues. Driving me nuts. I need my machine!!!!!!!!!!!!!!!!!!!
I also adjusted the valves. There was NO clearance on either the exhaust OR the intake valves. Tough to do with out taking the head off but, it can be done........made no difference. It will idle ALL day. As soon as you try and rev it, it dies. It will start right back up but wouldn't pull itself out of a mud puddle............................HELP
 
1 - 5 of 5 Posts
Top