Yamaha Grizzly Forum banner
21 - 23 of 23 Posts

·
Premium Member
Joined
·
7,680 Posts
That chunk of rubber HAD to come from somewhere... Check upstream to see where there's a piece of something missing...
 

·
Registered
Joined
·
2 Posts
same **** just happened to me.
-on the bottom of the carb there is a small screw.
back it off and see if you got fuel getting to the carb.
it will drain out of a small port just in front or back of the small screw
but even if fluid does drain out it still does not mean the carb is not pluged some where.
-if you do not have fuel
pull the main fuel line off with the petcock in off
after the main fuel line is off open the petcock and see if you have fuel
there
-if you do have good flow there
than i would say pull the carb
-if you do not have good flow the petcock maybe jacked up

i had to pull my carb. and take the whole thing apart and dunk it in a carb dip

works great now

after doing some insp.there was a nice build up of filter oil in the intake
and i think that is what pluged mine up

hope this helps
FR660
Yes we're having the same exact problems. Just got the Grizzley back from the ATV mechanic shop--they soaked the carburetor , started just fine at their shop, bring it home, everything works great, parked for 2 days and now it won't start again.

The battery shows a full charge--any suggestions would be great!
 

·
Registered
Joined
·
1 Posts
Hello! I have a 2014 yamaha grizzly 700 se that i just rebuilt the engine on it. The engine has spark. When I free spin engine without spark plug it spins fine and when i put spark plug back in it sounds like engine won't turn because of compression. I checked timing TDC and everything is good. All my clearances are good on my intake and exhaust valves.
 
21 - 23 of 23 Posts
Top