Yamaha Grizzly Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey All,

Brand new, bought an old Grizzly on a whim because my neighbor let me take my 4 yr old for a spin on his Kodiak thru trails at the end of our street. Kid was squeeling laughing through mud puddles….asking me every day to get a “mobile”. How could I say no…miles of trails through woods to explore.

Don’t know a thing but I’ll try to learn.

MA/NH line

Andy
 

Attachments

·
Registered
Joined
·
9 Posts
You bought a great machine, it looks like it’s been well taken care of.
I got my 1999 from my Brother, who bought it new, it’s a great machine, like you it’s my first 4 wheeler.
I can’t say mine looks nearly as good as yours (but hey it was free) it’s never had an issue that I couldn’t take care of on my own.
One issue we did experienced and read others have too is with the wiring harness (remove seat look at harness right side of frame) in my opinion harness is routed poorly (at least on my 99’). Older machines w/high miles may experience insulation worn off of wiring causing odd electrical issues. In my case the starter was self engaging while running which ruined starter and flywheel, (twice) which is why my Brother gave up on it and offered it to me. It took me a while to figure out what was causing the issue, oil temp light would also come on randomly, hopefully you don’t experience this, but if you do it’s an easy fix, unless it goes on too long and eats the flywheel/starter.

Enjoy the new toy (mobile)!

Mike
 
1 - 2 of 2 Posts
Top