Yamaha Grizzly Forum banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
239 Posts
griss dog if i where you i would pm grizz hopper and ask for his 2 cents he knows quit a bit about grizzlys
 

·
Premium Member
Joined
·
2,962 Posts
Could it be a short in the switch on the handelbars?
 

·
Registered
Joined
·
1,337 Posts
I little WD40 spray on the hadlebar switch could fix the contact (I had that on my cut off switch a while back)
 

·
Registered
Joined
·
1,337 Posts
grizzdog, I have the same problem today. What was the problem with yours?
 

·
Registered
Joined
·
26 Posts
I'm certainly no expert, BUT according to my service manual, there are three relays. In the ladder check sequence, check main fuse, which you did and it checked good, then next check the switch(on handle bars, for continuity, good, then move to battery, but we'll assume your's is good, then check main switch and then the three relays, if you want the break down on how to check the relays, let me know and I'll type it all out for ya! After the three relays, there is another switch called the "on-command 4-wheel drive switch and differential gear lock switch", and the last thing is the gear motor!
So, it could be either one of two switchs, or could be anyone of three relays, or the motor is toast.
gopod luck!!
 

·
Registered
Joined
·
1,337 Posts
Thanks,

Yesterday I checked cleaned and greased all the wiring harnesses and plugs.
I checked the switch, I had nothing to test the relays, so I took it into Yamaha today. It was due for the 7200km service any way!

I also hope I did not cook the motor, because if I did, I wont be buying new rims for a while!!!
 
1 - 9 of 9 Posts
Top