Yamaha Grizzly Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a problem. I installed a winch, and after I finished the reverse light stays on, and I can't get it to go off. Even when I am in another gear the red reverse light stays on. Can anyone help?
 

·
Registered
Joined
·
339 Posts
Time to start back tracking and making sure you know exactly what wires you spliced into for your power and what did you use for ground. Also check all of your connections of wires wherever you ran your winch lines. Check the connectors on the left side under the gas tank.
 

·
Premium Member
Joined
·
786 Posts
what are you calling the RED reverse light,,,, unless you hooked up a seperate light for reverse the grizz has no reverse light,,, has a stop light and a tail light,, im not sure if the tail light burns all the time the grizz is running or not,,someone on here can tell you, ,,, I guess what im saying is it might be normal and you never noticed it untill after the winch install,,, good luck,,,, ,,,,, cg
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
The red reverse light is on the dash where you have L H N R P. The R light for reverse will not go off.
 

·
Premium Member
Joined
·
159 Posts
like dknarnd said it's time to back track. which wires did you use?
 

·
Premium Member
Joined
·
786 Posts
stupid me,,, i get like that sometimes,,,, probably need to backtrack like dk said while I go sit in the corner looking stupid for a while,,,,,,,, ,,,,, cg
 

·
Premium Member
Joined
·
2,962 Posts
CG it's time to back-track to the fridge and get another beer.
 

·
Registered
Joined
·
382 Posts
sounds like you may have accidentantly provided a constant hot for the reverse LED or if it has a switchable ground provided a constant ground...either way a careful review of all your connections will turn up the answer. if you cant find it start disconnecting wires one at a time till the light goes out.
 
1 - 8 of 8 Posts
Top